⚡ Ford Lightning Forum ⚡ banner

Latest software update - over reporting range (Ford Power-Up)

6925 Views 53 Replies 27 Participants Last post by  cwstnsko
Hi Folks,

At the last software update, related to range - my range drastically dropped.
I figured it was just a winter thing so ignored it.

Then yesterday, I applied the 22-PU1009-MIL-DTE update (Received Jan 08) and after a full 100% charge my range went to 515 km!!!

I checked again and now it's reporting 505km.

I'm using the Ford Charger Pro.

Has anyone else seen an over-reporting charge?

Automotive parking light Tire Car Wheel Automotive side marker light

Font Parallel Number Document Screenshot
See less See more
1 - 2 of 54 Posts
Mine won’t install either. Tried multiple times (will keep trying daily until it works). Just get this message over and over:

We recently tried to install a Ford Power-Up software update for your 2022 F-150 but were unsuccessful. We’ll need your help to finish it. You’ll find detailed instructions on your in-vehicle screen (it’s pretty simple!). We’ll try the installation again at your next regularly scheduled update time. Thanks for your help. Ongoing updates like this help you enjoy the most updated version of your F-150.
  • Like
Reactions: 1
So I tried eight times and it didn’t work. Tonight I hooked up my battery charger to the tiny little starter battery in the lightning (it’s hilarious that it’s the size of my garden tractor battery). Anyway. It worked. I think the reason it failed to update eight times is because the truck was turned off and there wasn’t enough juice in the starter battery to complete the update or so the Ford computer thinks. I live in a cold climate so the starter battery is probably not at an optimal level and people in warmer climates may not be experiencing the update failure as much as we are. maybe they are too Anyways, that worked for me and it may not be related, but it seems more than coincidental. If you have one, try hooking up a battery charger to your starter battery to see if that gives it the stability to complete the update. It worked for me.
See less See more
1 - 2 of 54 Posts