⚡ Ford Lightning Forum ⚡ banner

Ford Charger not working

1120 Views 1 Reply 2 Participants Last post by  ChasingCoral
Boy - have I had problems. I had Sunrun install the very expensive home charger/backup power system two months before my Lariat arrived. Unaware to either me or the dealer the truck delivery was delayed for over two months as it was pulled for a random battery stability test for over two months. Anyway when Sunrun installed the system the Ford charger unit immediately displayed a solid amber fault light. And no matter how many power resets (and with a battery backup power supply on the control cards, you have to pull the charger cover so you can get at the backup power cord), and factory resets, the charger still does not work and going on three weeks it seems like Ford, Siemens and Sunrun have not been able to get it working. My unintelligent analysis is that the Bluetooth communication is either not enabled or is broken as NO Bluetooth appears in the scan. I did get the wireless communication connected and working so that Siemens can do diagnostics but they don't tell me what is wrong. I wonder how long I have to suffer with this before they just send me a new charger? The fact that I have to deal with Ford, Siemens and Sunrun is a bit daunting, frustrating as there appears to be no sense of urgency to fix this!

Ford needs to do a better when this happens - the dealer is a bit clueless.
  • Sad
Reactions: 1
1 - 1 of 2 Posts
1 - 1 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top